Podio Service Running Slowly
Incident Report for Podio
Resolved
Response times are back to normal levels.
Posted 3 months ago. Oct 02, 2017 - 16:42 EDT
Investigating
We are aware of elevated response times and are working to resolve the issue. Updates to follow.
Posted 3 months ago. Oct 02, 2017 - 13:04 EDT