We are seeing intermittent errors with GlobiFlow
Incident Report for Podio
Resolved
GlobiFlow has worked through the queue and is back to normal operations: http://status.globiflow.com/incidents/jyydn8p93f33
Posted 3 months ago. Feb 20, 2018 - 13:56 EST
Monitoring
Please follow along here: http://status.globiflow.com/
Posted 3 months ago. Feb 20, 2018 - 11:34 EST