Help pages are down
Incident Report for Podio
Resolved
Our help center is back, now we can finally support you again! \o/
Posted about 1 year ago. Oct 13, 2016 - 17:04 EDT
Identified
Our help desk is down. Our provider is aware of the problem and working on a fix.
Posted about 1 year ago. Oct 13, 2016 - 14:30 EDT