Intermittent network issues
Incident Report for Podio
Resolved
This incident has been resolved.
Posted about 2 years ago. Dec 17, 2015 - 16:53 EST
Monitoring
All services should be functioning. We are monitoring the situation.
Posted about 2 years ago. Dec 17, 2015 - 16:24 EST
Identified
We are currently experiencing some network issues, which affects the connectivity to Podio in some cases.
Posted about 2 years ago. Dec 17, 2015 - 16:00 EST