Very slow system
Incident Report for Podio
Resolved
We're back to normal
Posted almost 2 years ago. Mar 07, 2016 - 10:30 EST
Identified
Podio is very slow at the moment, we think we have a solution and are working on it.
Posted almost 2 years ago. Mar 07, 2016 - 10:11 EST