Podio Service Running Slowly
Incident Report for Podio
Resolved
Response times are back to normal levels. We are aware that this is a recurring issue and will be performing several database upgrades over the coming weeks to improve performance.
Posted 3 months ago. Sep 26, 2017 - 13:15 EDT
Investigating
We've received reports of the Podio service running slowly. Our engineering team is aware and we will provide updates as they become available.
Posted 3 months ago. Sep 26, 2017 - 10:23 EDT