Podio is unavailable
Incident Report for Podio
Resolved
All systems are back and running again.
Posted over 1 year ago. Mar 16, 2016 - 03:50 EDT
Monitoring
Our queuing system failed - the issue is solved now and we continue to monitor.
Posted over 1 year ago. Mar 16, 2016 - 03:41 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Mar 16, 2016 - 03:20 EDT