help.podio.com is currently down
Incident Report for Podio
Resolved
help.podio.com is back again! Our provider is still experiencing a service degradation and service might not be 100 % stable until they are fully recovered. We are sorry for the inconvenience.
Posted about 1 month ago. May 22, 2017 - 10:32 UTC
Monitoring
Our knowledge base and support channel provider is experiencing issues and the help pages are down. Our provider is aware of the problem and working on a fix. You can continue to write us via support@podio.com and we'll get back to you as soon as possible.
Posted about 1 month ago. May 22, 2017 - 10:26 UTC