Podio.com intermittently unavailable
Incident Report for Podio
Resolved
All services operational.
Posted about 1 month ago. Sep 06, 2017 - 17:11 EDT
Monitoring
We have identified the issue causing intermittent availability and the site is now functioning normally. We are closely monitoring to prevent further disruption.
Posted about 1 month ago. Sep 06, 2017 - 13:18 EDT
Investigating
We are seeing intermittent issues accessing podio.com and are working to identify the root cause. We apologize for any inconvenience this issue may have caused, and will provide additional information as it's available.
Posted about 1 month ago. Sep 06, 2017 - 12:58 EDT