Delayed mail deliveries
Incident Report for Podio
Resolved
Emails have been delivered now.
Posted about 2 years ago. Nov 03, 2015 - 13:21 EST
Monitoring
Emails are starting to be delivered again. We are monitoring the situation closely.
Posted about 2 years ago. Nov 03, 2015 - 10:09 EST
Investigating
We are currently experiencing delayed email deliveries. We are looking into the issue.
Posted about 2 years ago. Nov 03, 2015 - 09:53 EST