Podio Service Running Slowly
Incident Report for Podio
Resolved
Response times are back to normal levels. The scheduled maintenance tomorrow should help to alleviate the recurring service degradation. Thank you for your patience.
Posted 3 months ago. Sep 27, 2017 - 13:29 EDT
Investigating
We are aware of elevated response times and are working to resolve the issue. Updates to follow.
Posted 3 months ago. Sep 27, 2017 - 11:11 EDT