Service issues
Incident Report for Podio
Resolved
We have rectified the situation and Podio is back.
Posted almost 2 years ago. Aug 17, 2016 - 10:46 EDT
Investigating
We're seeing service with API and frontend dropping out. We are looking into the issue.
Posted almost 2 years ago. Aug 17, 2016 - 10:36 EDT