Podio.com running slowly
Incident Report for Podio
Resolved
All services operational and the queues are back down to normal levels. More details on the incident to follow.
Posted 3 months ago. Sep 21, 2017 - 14:11 EDT
Investigating
Podio.com is running slowly - we are investigating the cause of the delays.

Thank you for your continued patience while we look into this.
Posted 3 months ago. Sep 21, 2017 - 12:50 EDT