GlobiFlow experiencing slowness
Incident Report for Podio
Resolved
GlobiFlow is operating a normal speed at this point. We'll be scheduling additional maintenance in the future to continue to stabilize performance on GlobiFlow side.
Posted 3 months ago. Mar 19, 2018 - 14:38 EDT
Identified
We are working through general slowness on the GlobiFlow side and will keep customers updated here: http://status.globiflow.com/
Posted 3 months ago. Mar 19, 2018 - 12:14 EDT