Intermittent networking issues
Incident Report for Podio
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 17, 2015 - 11:56 EST
Monitoring
The issue has been fixed by our provider. We'll continue to monitor.
Posted almost 2 years ago. Nov 17, 2015 - 11:35 EST
Identified
Our provider is working on fixing the connectivity issues.
Posted almost 2 years ago. Nov 17, 2015 - 10:46 EST
Investigating
We are seeing intermittent issues reaching podio.com
Posted almost 2 years ago. Nov 17, 2015 - 10:24 EST