Performance issues
Incident Report for Podio
Resolved
Issue has been resolved.
Posted about 1 month ago. Jul 21, 2017 - 16:51 UTC
Monitoring
Performance issues have been identified and corrective measures in place. Performance has been steadily improving and we are continuing to monitor
Posted about 1 month ago. Jul 21, 2017 - 16:02 UTC
Investigating
We are currently investigating a performance issue that is increasing delay times in calculations. Updates to follow
Posted about 1 month ago. Jul 21, 2017 - 13:51 UTC