SSL certificate problems for some users
Incident Report for Podio
Resolved
We've applied our providers fix to production. We believe this has issue has been resolved, but if you are still having problems reaching Podio please reach out to support@podio.com
Posted 10 months ago. Oct 14, 2016 - 04:21 UTC
Update
If you are having problems reaching Podio due to certificate issues, please try clearing your OCSP cache. Guide here: https://support.globalsign.com/customer/portal/articles/1353318 . We are still waiting for a fix from our provider.
Posted 10 months ago. Oct 13, 2016 - 21:55 UTC
Update
Our provider has identified the root cause and we will be implementing a fix ASAP
Posted 10 months ago. Oct 13, 2016 - 18:33 UTC
Identified
Some users are seeing SSL/HTTPS certificate errors. This is a global issue affecting other sites as well. We are waiting on a fix from our SSL provider, there is unfortunately not much we can do ourselves.
Posted 10 months ago. Oct 13, 2016 - 11:34 UTC