Podio workflow automation intermittently unavailable
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 08:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2021 - 08:19 EDT
Identified
Podio workflow automation is intermittently unavailable. Workflows continue to trigger with a high delay.
Posted Apr 15, 2021 - 07:46 EDT
This incident affected: Advanced Workflow Automation.