Delay in background tasks and calculations
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 11:44 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 14, 2022 - 11:33 EDT
Investigating
We are currently investigating this issue.
Posted Jun 14, 2022 - 10:41 EDT
This incident affected: Web and API.