Citrix Podio Workflow Automation Service and webhook flows experiencing delays
Incident Report for Citrix Podio Status Page
Resolved
Podio Workflow Automation Service and webhook flows have recovered and operational
Posted Feb 03, 2022 - 16:28 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2022 - 15:40 EST
Investigating
The Citrix Engineering team is engaged and working on the issue
Posted Feb 03, 2022 - 15:27 EST
This incident affected: Web and API.