Some Podio might be experiencing intermittent delays
Incident Report for Citrix Podio Status Page
Resolved
This issue have been resolved. Thank you for your patience.
We regret the inconvenience caused to our users.
Posted Jul 21, 2022 - 05:48 EDT
Monitoring
A fix has been implemented. There should be no delays now.
We will continue to monitor the situation for sometime.
Posted Jul 21, 2022 - 05:02 EDT
Identified
The issue has been identified and a fix is being implemented for customers who are facing these delays
Posted Jul 21, 2022 - 02:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2022 - 09:27 EDT
Investigating
We are currently investigating this issue.
Posted Jul 20, 2022 - 09:02 EDT
This incident affected: Email and Advanced Workflow Automation.