Severe performance degradation and outage

Incident Report for Podio Status Page

Resolved

We have identified the root cause and have made configuration changes to ensure that a similar situation does not occur again.
Posted Mar 18, 2014 - 08:38 EDT

Monitoring

There was a severe performance degradation on the main database, which caused Podio to be unavailable for 10 minutes. We have made a change that solved the issue and we will continue to monitor the load. We will follow up additional details later.
Posted Mar 18, 2014 - 08:16 EDT