Email Notifications not working

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted 30 days ago. Mar 10, 2025 - 13:03 EDT

Monitoring

Fix has been made and we are monitoring the results..
Posted 30 days ago. Mar 10, 2025 - 11:33 EDT

Identified

Issue has been identified and we are working with our Email Provider
Posted 30 days ago. Mar 10, 2025 - 08:09 EDT

Update

We are continuing to investigate this issue.
Posted 30 days ago. Mar 10, 2025 - 07:45 EDT

Investigating

We are working with our Email Provider
Posted 30 days ago. Mar 10, 2025 - 07:45 EDT
This incident affected: Email.