Workflow automation trigger delay
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted May 04, 2021 - 14:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2021 - 14:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2021 - 13:15 EDT
Investigating
We are currently investigating this issue.
Posted May 04, 2021 - 13:02 EDT
This incident affected: API and Advanced Workflow Automation.