This incident has been resolved. No further impact has been observed and we are considering this issue to be resolved based on our system monitoring. If you are still experiencing any issues, please let us know via support at Help Center: https://support.sharefile.com/s/
Posted Mar 15, 2026 - 03:47 EDT
Monitoring
AWS ElastiCache service stability is improving, and Podio is beginning to recover. We are monitoring the platform closely to ensure performance returns to normal levels. Some users may still experience intermittent issues during this period.
Posted Mar 15, 2026 - 02:43 EDT
Identified
We have identified that the ongoing Podio performance issues are related to a disruption in the AWS ElastiCache service. This may result in slow responses or intermittent failures across parts of the platform. We are applying mitigations and closely monitoring the situation while AWS works on resolving the underlying issue.
Posted Mar 15, 2026 - 02:34 EDT
Investigating
We are currently investigating an issue impacting Podio due to problems with the AWS ElastiCache service. Some users may experience degraded performance or intermittent errors when accessing Podio. Our team is actively working with AWS to identify the root cause and mitigate the impact.