Delay with background tasks
Incident Report for Podio
Resolved
This incident has been resolved.
Posted Sep 30, 2019 - 17:26 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2019 - 16:29 EDT
Identified
We are aware of a delay with background tasks such as import/export and calculations.
Posted Sep 30, 2019 - 12:10 EDT
This incident affected: Web.