Podio is Slow - Response Times Elevated
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 15:05 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2021 - 13:32 EST
Investigating
We are currently investigating this issue.
Posted Mar 10, 2021 - 11:20 EST
This incident affected: Web and API.