Citrix Podio is experiencing issues causing delays for workflow automation and webhooks
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.

If workflows were not triggering in a timely manner during this incident, customers might need to re-trigger their workflows or webhooks to ensure automation goes through.
Posted Nov 29, 2021 - 22:59 EST
Monitoring
Mitigation activity has been implemented and we are currently monitoring the results.

If workflows were not triggering in a timely manner, customers might need to re-trigger their workflows or webhooks to ensure automation goes through after this incident is resolved.
Posted Nov 29, 2021 - 22:29 EST
Identified
The issue has been identified and a fix is being implemented.

If workflows were not triggering in a timely manner, customers might need to re-trigger their workflows or webhooks to ensure automation goes through after this incident is resolved.
Posted Nov 29, 2021 - 22:14 EST
Investigating
Impact:
Citrix Podio is experiencing issues causing delays for workflow automation and webhooks. Customers may experience delays for workflow triggers and webhooks.

Current Status:
The Citrix Engineering team is engaged and investigating the issue. At present there are no identifiable work arounds or ETA for a fix.
Posted Nov 29, 2021 - 21:45 EST
This incident affected: API and Advanced Workflow Automation.