Podio Web application is down.

Incident Report for Podio Status Page

Resolved

Systems back to normal working state.
Posted 1 year ago. Oct 12, 2023 - 14:06 EDT

Monitoring

Systems Operational and we are monitoring.
Posted 1 year ago. Oct 12, 2023 - 13:54 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted 1 year ago. Oct 12, 2023 - 13:01 EDT

Update

We are continuing to investigate this issue.
Posted 1 year ago. Oct 12, 2023 - 11:57 EDT

Investigating

Podio web application is down , we are investigating .
Posted 1 year ago. Oct 12, 2023 - 11:47 EDT
This incident affected: Web, API, and Email.