Citrix Podio seeing intermittent issues and delays
Incident Report for Citrix Podio Status Page
Resolved
This issues have been resolved and the root cause identified. Thanks for your patience.
Posted Dec 21, 2021 - 02:26 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 21, 2021 - 02:20 EST
Monitoring
A fix has been implemented and all pages seem to be loading fine now. We will continue monitoring the performance for a while.
Posted Dec 21, 2021 - 02:14 EST
Investigating
We are seeing intermittent issues on pages loading user profiles on Podio UI. We are currently investigating the issue.
Posted Dec 21, 2021 - 02:10 EST
This incident affected: Web and API.