Podio is not accessible
Incident Report for Podio
Resolved
A configuration issue in the load balancer caused this outage. This has been fixed.
Posted Mar 10, 2020 - 02:56 EDT
Investigating
We are currently investigating this issue.
Posted Mar 10, 2020 - 02:18 EDT
This incident affected: Web, API, and Email.