Podio Workflows is Experiencing Delays

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted 2 years ago. Sep 22, 2023 - 12:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 2 years ago. Sep 22, 2023 - 11:47 EDT

Investigating

We are investigating customer reports of an issue impacting performance of Podio Workflows causing delays for users. We will provide updates here as soon as possible.
Posted 2 years ago. Sep 22, 2023 - 11:33 EDT
This incident affected: Advanced Workflow Automation.