Citrix Podio service customers may be experiencing issues...
Incident Report for Citrix Podio Status Page
Postmortem

Citrix Engineering concluded the 48HR Summary RCA. Please see the following link for the Root Cause Analysis (RCA) detailing what happened, how it was mitigated, and next steps to prevent a similar reoccurrence. We deeply apologize for any inconvenience this outage may have caused.

48HR Summary RCA: https://citrix.sharefile.com/d-sc85595351cab438ea7efb036bfd21d3e

Posted Dec 02, 2021 - 13:17 EST

Resolved
The implemented fix has resolved the issue. Citrix Podio is now fully operational.
Citrix Engineering team will be conducting a review to improve and prevent similar performance issues in the future. If you need further assistance, please reach out to Technical Support.
We apologize for the inconveniences this incident has caused you and your customers.
Posted Dec 01, 2021 - 22:46 EST
Monitoring
Citrix Engineering has mitigated the issue by implementing a fix and is monitoring closely. If further issues are seen, please contact Technical Support.
Posted Dec 01, 2021 - 21:51 EST
Update
Citrix Engineering continues to work on mitigating the issues experienced by Podio users. Citrix Podio is functional and responsive, however, some services are still degraded. Real-time updates, calculations, web-hooks and workflows are still being affected.
Posted Dec 01, 2021 - 21:25 EST
Update
Citrix Podio is functional and responsive, however, some services are still degraded. Real-time updates, calculations, web-hooks and workflows are still being affected. We continue to investigate the root cause for the degraded services.
Posted Dec 01, 2021 - 20:49 EST
Update
Citrix Engineering continues to work diligently on mitigating the issue seen by Podio users. More information will be provided as it becomes available.
Posted Dec 01, 2021 - 20:28 EST
Identified
Citrix Engineering has identified an issue and are working on a fix. Investigation continues to address the issue. More information will be provided as it becomes available.
Posted Dec 01, 2021 - 19:33 EST
Update
Citrix Engineering continues to investigate the issue. The team is actively investigating a component that may be affecting the outage. More information will be provided as it becomes available.
Posted Dec 01, 2021 - 19:02 EST
Update
Citrix Engineering continues to investigate and attempt to mitigate the issue. Customers may be experiencing issues affecting all Citrix Podio components. The team will provide additional information as it becomes available.
Posted Dec 01, 2021 - 18:41 EST
Investigating
Citrix Engineering is currently investigating intermittent availability and slow queue consumption affecting all Citrix Podio components. The team will provide additional information within 60 minutes or sooner.
Posted Dec 01, 2021 - 17:30 EST
This incident affected: Web and API.