Podio workflow automation is temporarily unavailable

Incident Report for Podio Status Page

Resolved

This incident has been resolved. No further impact has been observed, and we are considering this issue to be resolved based on customer feedback and our system monitoring. If you are still experiencing any problems, please let us know via support at Help Center https://support.sharefile.com/s/
Posted Oct 07, 2025 - 13:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2025 - 13:18 EDT

Identified

The issue has been identified, and we are actively working on a resolution. We expect the experience to be back to normal shortly.
Posted Oct 07, 2025 - 13:14 EDT

Investigating

We are investigating customer reports of Podio workflow automation being unavailable. We will provide updates here as soon as possible.
Posted Oct 07, 2025 - 12:57 EDT
This incident affected: Advanced Workflow Automation.