Podio performance issues resolved
Incident Report for Podio Status Page
Postmortem

Podio Service Event - Oct 26 - 27 2024

Summary of Impact

On October 26th and 27th, 2024, Podio customers encountered performance issues, including login disruptions and general unavailability. This impacted the ability of users to access and utilize Podio, affecting workflows and client engagements.

Root Cause

On October 26th, we conducted a scheduled maintenance event from 9:30 AM to 11:30 AM IST to upgrade our database infrastructure. Upon transitioning traffic to the upgraded database post-maintenance, we noticed a substantial increase in CPU utilization alongside an elevated number of active sessions. This surge caused slow performance, preventing many users from successfully logging in. The continued high demand ultimately led to temporary service interruptions.

Mitigation

Immediate Actions: Our team, in collaboration with third party support, investigated the potential sources of the performance lag and identified that multiple composite indexes in use were contributing to slow query execution times.

Resolution Timeline: By 1:30 PM IST on October 26th, we optimized several queries to improve response times. We communicated this update on our status page, noting improvements. However, some users experienced issues with category/date filters in Podio apps, which we resolved by 3:00 PM IST on October 27th.

Full Restoration: By 3:30 PM IST on October 27th, all identified issues were resolved, restoring Podio services to normal operation.

Next Steps

  • Third Party Collaboration: Continue to work closely with third parties to understand the increased query execution times experienced in the new database environment.
  • Rollback Strategy: We already have a general strategy in place, but moving forward, we will implement a more robust rollback plan for database upgrades to further reduce risks and ensure seamless experience. 
  • Query Optimisation: We are prioritising ongoing analysis and optimisation of high-demand queries to ensure improved performance and stability.

Our Commitment to Service, Reliability and Performance

Thank you for your patience and understanding as we work to enhance the reliability of our services. Please feel free to reach out to our support team via 24/7 active chat support.

Posted Nov 05, 2024 - 03:30 EST

Resolved
Podio is stable and issue marked as resolved.
Posted Oct 26, 2024 - 18:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2024 - 15:36 EDT
Update
Following the database maintenance yesterday, we began experiencing spikes in CPU utilisation. Certain complex queries with multiple indexes are causing bottlenecks and negatively affecting performance. We have identified some of these issues and are working on the fixes, but the process is taking longer than anticipated. We apologize for the long wait for the resolution but also thank you for your patience. Be rest assured our team is working on this with highest priority.
Posted Oct 26, 2024 - 14:08 EDT
Update
We're still troubleshooting the issue to get Podio back as soon as possible.
Posted Oct 26, 2024 - 13:36 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 26, 2024 - 11:50 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 26, 2024 - 11:49 EDT
Update
We are still working to optimize Podio's performance.
Posted Oct 26, 2024 - 09:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 26, 2024 - 08:08 EDT
Investigating
We are currently investigating this issue.
Posted Oct 26, 2024 - 05:36 EDT
This incident affected: Web, API, Email, and Advanced Workflow Automation.