Delayed exports and bulk calculations

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted May 10, 2025 - 03:46 EDT

Update

Delays have reduced significantly. However, we will continue monitoring the system for a couple more hours to ensure all operations are back to normal.
Posted May 09, 2025 - 18:41 EDT

Monitoring

Our fix has started working and delays are reducing. We will continue monitoring the system to ensure the delays are completely resolved.
Posted May 09, 2025 - 16:31 EDT

Update

We have performed a couple more optimizations. The background and bulk operations are picking up speed again. We believe the delay should soon be over.
Posted May 09, 2025 - 15:56 EDT

Update

We have applied a fix but it is taking a little longer to show effect. We continue monitoring the system and investigating more mitigation steps.
Posted May 09, 2025 - 12:51 EDT

Identified

We have identified the issue and are in the process of mitigating the cause for these delays.
Posted May 09, 2025 - 11:52 EDT

Investigating

We are seeing delays in certain background operations like excel export, excel import, bulk calculations and cloning of apps. Our team is currently investigating the issue and we will update this page as soon as we know more.
Posted May 09, 2025 - 11:47 EDT
This incident affected: API.