Citrix Podio experiencing webhook delays
Incident Report for Citrix Podio Status Page
Resolved
Webhooks have been performing better once the temporary fix was implemented on Friday. Our engineering team continues to work on a permanent fix, which will required some additional adjustments to our infrastructure. We will be scheduling a maintenance event in the near future to help scale out infrastructure for webhooks and address the delays in the longterm. Thanks for your patience.
Posted Feb 01, 2022 - 09:23 EST
Update
We have been able to identify a potential root cause for the delays and the team pushed a fix this morning to address it. We have seen better performance today after the change but will continue to monitor through Monday to ensure we can handle the load Monday as well before closing the incident. Thanks for your patience as we work through improving the speed of webhooks.
Posted Jan 28, 2022 - 13:34 EST
Update
Citrix Engineering team is still investigating the cause of the webhooks delays and how to handle increased load on this part of our infrastructure. We will continue to monitor the performance until we have adressed the root cause for the delays
Posted Jan 27, 2022 - 18:28 EST
Update
Webhooks performance has recovered and is not showing any delays currently. We will continue monitoring the performance for a while
Posted Jan 27, 2022 - 13:46 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2022 - 12:45 EST
Investigating
Citrix Engineering team is engaged investigating issues causing webhook delays/processing slower than normal
Posted Jan 27, 2022 - 11:52 EST
This incident affected: Web and API.