Podio is temporarily unavailable

Incident Report for Podio Status Page

Resolved

This incident has been resolved. No further impact has been observed and we are considering this issue to be resolved based on feedback from customers and our system monitoring. If you are still experiencing any issues, please let us know via support at Help Center: https://support.sharefile.com/s/

We apologize for the impact of this issue for your business and are taking steps to reduce the likelihood of this occurring again in the future.
Posted Aug 21, 2025 - 05:01 EDT

Monitoring

We are seeing better performance of search based on team efforts to resolve and are actively monitoring.
Posted Aug 21, 2025 - 04:15 EDT

Identified

The issue has been identified and we are actively working on a resolution. We expect the experience to be back to normal shortly.
Posted Aug 21, 2025 - 04:09 EDT

Investigating

We are investigating customer reports of Podio being unavailable. We will provide updates here as soon as possible.
Posted Aug 21, 2025 - 04:05 EDT
This incident affected: Web, API, Email, and Advanced Workflow Automation.