Mobile apps not connecting
Incident Report for Citrix Podio Status Page
Resolved
We believe this incident has been fully resolved and the internal RCA is in progress. If you still receive connection error make sure to update to latest version of the mobile apps Version 20.8.5 for iOS and 20.8.1 for Android. Let us know in Support if you have any issues and we will be happy to assist: https://help.podio.com/hc/en-us and hit "Contact Support".
Posted Aug 31, 2020 - 08:50 EDT
Monitoring
We have implemented a fix and you should be able to connect to the mobile apps again. We are very sorry for the disruption and will be conducting internal RCA to understand how to avoid a similar connection issue in the future.
Posted Aug 29, 2020 - 12:06 EDT
Identified
We are aware of an issue causing mobile apps not to connect and team is working on pushing a fix through as fast as possible, unfortunately we cannot promise an ETA yet as we need both apps to go through iOS and Android review process. We are very sorry for this disruption to your weekend and not being able to access your data on the go.
Posted Aug 29, 2020 - 07:21 EDT