Podio Mobile Users may be experiencing issues accessing new items on the mobile app
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 02:36 EDT
Monitoring
The fix for iOS is now available on App Store. Please download the latest version of the app v22.7.0
The fix for Android can also be downloaded from the Play Store - v22.7.0
We regret the inconvenience caused.
Posted Jul 05, 2022 - 01:05 EDT
Update
The fix for iOS is now available on App Store.
Please download the latest version of the app v22.7.0
Posted Jul 05, 2022 - 00:57 EDT
Update
We will update when the fixes are available for all Podio Users
Posted Jul 04, 2022 - 06:17 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 04, 2022 - 06:16 EDT
Update
We will update when the fixes are available for all Podio Users
Posted Jul 04, 2022 - 06:16 EDT
Update
A fix has been deployed for iOS as well and is awaiting approval from App Store

The fix for Android has been rolled out for Android App on Play Store Beta

For joining Beta from your Android device, follow these steps:
1) Open Play Store on the Android device
2) Find Podio in Play Store and go to the Podio app listing
3) Scroll to the bottom of the page and click 'Join Beta'

Joining Beta takes time sometime due to Google app caching. Restarting the device will help. The rollout on production is in progress and will be completed soon. We will update when the fixes are available for all Podio Users
Posted Jul 04, 2022 - 05:14 EDT
Identified
The issue has been identified and a fix is being rolled out both for iOS and Android
Posted Jul 04, 2022 - 04:34 EDT