Podio customers may be experience some queue delays

Incident Report for Podio Status Page

Resolved

The queue delays have been resolved. We regret the inconvenience caused to our customers.
Posted 3 years ago. Oct 07, 2022 - 03:25 EDT

Monitoring

The delays in calculations and webhooks have now reduced and queues seem to be processing normally.
We will continue to monitor the situation to ensure no further delays happen
Posted 3 years ago. Oct 07, 2022 - 02:56 EDT

Update

Bulk background tasks like data export and import, calculations and webhooks are experiencing delays.
We are continuing to investigate further to find the root cause of this issue
Posted 3 years ago. Oct 07, 2022 - 02:43 EDT

Investigating

Citrix Podio users may be experiencing delays
Posted 3 years ago. Oct 07, 2022 - 02:33 EDT