Podio experiencing latency issues
Incident Report for Podio
Resolved
Response times are back to normal
Posted Feb 26, 2020 - 14:18 EST
Identified
A fix has been implemented and we'll monitor the results
Posted Feb 26, 2020 - 12:50 EST
Investigating
We are currently investigating latency issue
Posted Feb 26, 2020 - 11:07 EST
This incident affected: Web and API.