Podio not loading for some customers
Incident Report for Podio
Resolved
We have a good idea on root cause and how to better prevent same interruption in the future, Podio operations has been back to normal the last hour and we are closing this incident.
Posted Sep 10, 2019 - 14:12 EDT
Monitoring
We are monitoring and team is continuing to investigate the root cause. Podio response times is back to normal at this point.
Posted Sep 10, 2019 - 13:20 EDT
Identified
We have identified the issue and Podio response times is getting back to normal. Sorry for the interruption! Team is looking into the cause.
Posted Sep 10, 2019 - 13:16 EDT
Investigating
We are currently investigating the issue.
Posted Sep 10, 2019 - 13:10 EDT
This incident affected: Web and API.