Podio end-users may be experiencing issues with Excel

Incident Report for Podio Status Page

Resolved

The delays have been resolved. If any further issues are seen, please contact Citrix Technical Support.
Posted 3 years ago. May 04, 2022 - 21:06 EDT

Monitoring

We have known delays for bulk background tasks related to Excel export, imports and bulk calculations following the incident earlier today. The underlying problem has been resolved and the work is slowly catching up, we expect delays to be resolved in the next few hours. We will update when delays are back to normal.
Posted 3 years ago. May 04, 2022 - 18:10 EDT

Investigating

Due to a prior incident, Podio end-users may be experiencing issues with Excel import/export and bulk calculations. Citrix engineers are currently monitoring and will provide an update with the delays are resolved.
Posted 3 years ago. May 04, 2022 - 18:03 EDT
This incident affected: Web.