Podio users experiencing latency with search

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted 1 year ago. Nov 14, 2023 - 11:08 EST

Identified

The issue has been identified and a fix is being implemented.
Posted 1 year ago. Nov 14, 2023 - 10:38 EST

Investigating

We are currently investigating this issue.
Posted 1 year ago. Nov 14, 2023 - 10:36 EST
This incident affected: Web, API, Email, Advanced Workflow Automation, and Advanced Workflow Automation Failover Queue.