Podio is temporarily not accessible
Incident Report for Citrix Podio Status Page
Resolved
The implemented fix has resolved the issue. Citrix Podio - Web component is now fully operational.
We apologise for the inconvenience this incident has caused.
Posted Jan 12, 2022 - 02:35 EST
Monitoring
The fix has been implemented and we are currently monitoring the results
Posted Jan 12, 2022 - 02:26 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2022 - 02:25 EST
Update
We are continuing to investigate this issue
Posted Jan 12, 2022 - 02:21 EST
Update
The issues seen on Podio are restricted only to the web. All other aspects like API, Email and Workflow Automation are all working fine.
Posted Jan 12, 2022 - 02:01 EST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2022 - 01:55 EST
Investigating
Podio is seeing issues and not accessible right now. Our team is investigating and we are working to get it fixed at the earliest.
Posted Jan 12, 2022 - 01:54 EST
This incident affected: Web, API, Email, and Advanced Workflow Automation.