Podio operations may be experiencing issues

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted 1 year ago. Mar 26, 2024 - 11:59 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Mar 26, 2024 - 11:55 EDT

Update

We are continuing to investigate this issue.
Posted 1 year ago. Mar 26, 2024 - 10:14 EDT

Investigating

We are investigating customer reports of an issue impacting performance of Podio causing slowness in the application and increased error rates for some customers. We will provide updates here as soon as possible.
Posted 1 year ago. Mar 26, 2024 - 10:01 EDT
This incident affected: Web and API.