A fix has been implemented, and we are monitoring the results.
Posted Jul 22, 2025 - 08:32 EDT
Identified
The issue has been identified and we are actively working on a resolution. We expect the experience to be back to normal shortly.
Posted Jul 22, 2025 - 08:31 EDT
Update
We are continuing to investigate this issue.
Posted Jul 22, 2025 - 05:57 EDT
Update
Some Podio customers may be experiencing issues with notifications. We are investigating this issue and will provide updates here as soon as they are available.
Posted Jul 22, 2025 - 00:27 EDT
Update
This issue is occurring intermittently and we continue to investigate it. Will re-iterate that if you see activity notifications not getting updated on Podio web, please refresh your browser to load it correctly. Thank you for your patience.
Posted Jul 21, 2025 - 14:35 EDT
Investigating
We have received customer reports of an issue with Podio notifications on web, especially notifications arising from item activities like updating an item or adding comments on an item. We are actively investigating this issue and will provide updates here as soon as possible. Please note that the email and mobile app notifications are working as expected.
Issue Detail: For users facing this issue, the updates or new comments are neither shown in the activity feeds of the related item / app/ workspace, nor do they bubble up as new notifications alert on top navigation pane, without a browser refresh. Refreshing the browser should show the activity fine.
Action Requested: Please be rest assured that any update you are making is getting registered as an activity for the item. The issue is with the web notifications. So will request users facing the issue to not repeat the updates as you would be duplicating or spending extra effort for an update that is already done. You can just hit refresh on your browser to confirm the activity is recorded.