Citrix Podio seeing Calculation delays
Incident Report for Citrix Podio Status Page
Resolved
This incident has been solved. In case your calculations failed, you might need to re-trigger them.
We regret the inconvenience caused.
Posted Aug 01, 2022 - 13:08 EDT
Monitoring
A fix has been implemented and calculation delays should now be solved.
In case your calculations failed, you might need to re-trigger them
Posted Aug 01, 2022 - 11:54 EDT
Identified
The team has identified a fix and we are working towards fixing calculations
Posted Aug 01, 2022 - 11:26 EDT
Investigating
We are currently investigating this issue.
Posted Aug 01, 2022 - 11:13 EDT
This incident affected: Web.