Email Notifications Not Sending

Incident Report for Podio Status Page

Resolved

This incident has been resolved. If you are still experiencing any issues, please let us know via support.
Posted 29 days ago. Mar 09, 2025 - 18:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 29 days ago. Mar 09, 2025 - 17:23 EDT

Update

We're continuing to work with our email provider to resolve the issue.
Posted 29 days ago. Mar 09, 2025 - 15:07 EDT

Identified

We've identified the issue with our email provider and continue to work on resolving it.
Posted 29 days ago. Mar 09, 2025 - 12:15 EDT

Investigating

We are currently investigating this issue.
Posted 29 days ago. Mar 09, 2025 - 12:14 EDT
This incident affected: Email.